Joomla 3.3 compatibility

Joomla 3.3 has been released. The latest version of our templates (2.3.0) is already compatible with this version of Joomla. No patches are needed.

If you happen to find any issues or bugs feel free to contact us.